T5bobbo

Full Members
  • Content count

    27
  • Joined

  • Last visited

About T5bobbo

  • Rank

Previous Fields

  • Model of Volvo
    S60 (Saloon P2 99>)
  • Location (County)
    Lincolnshire
  • Location (Town/City)
    Brigg

Recent Profile Visitors

183 profile views
  1. Thanks for that. Although removing them isn't a problem as I've done loads of research on the "internet" on how to remove them. it's just which way is the best again hence my original question lol. Now can you see my original frustration lol. And my original post would have got me band lol. Sent from my Nexus 5X using Tapatalk
  2. I've looked and looked hence my original question of someone on here might have the mcgard removal kit. Thanks for your help. Bloody hell did someone just help me without been a complete bell smith? Sent from my Nexus 5X using Tapatalk
  3. Bottom lip came out and everything lol Sent from my Nexus 5X using Tapatalk
  4. If you read the question instead of trying to impress men on the internet with your wit then i think you will find the internet doesn't have the contents of everyone's garage/workshop tools which would be useful. You just couldn't wait to use that " iam a clever dick" link lol. Sent from my Nexus 5X using Tapatalk
  5. As in title if not where can i i get one? Thanks in advance Sent from my Nexus 5X using Tapatalk
  6. I upgraded the top mount about 3 months ago which made the car feel better now the bottom mount has failed. Might just order a new OEM one for now as Iam moving house soon and can't be bothered to mess about with it. Can someone tell me the torque settings as Iam yet to but a Haynes Sent from my Nexus 5X using Tapatalk
  7. Oh and it's a manual Sent from my Nexus 5X using Tapatalk
  8. It's an 03 plate s60 2.3 t5 250 bhp. Got a knock everytime i lift off or accelerate or get the biting point. Checked the transmission mount and the small bush has warn away so wondering if an uprated version is the better option Sent from my Nexus 5X using Tapatalk
  9. Nice one thanks that's a great help I'll have a look see the relay later. Plus Iam thinking the tracking is settling back to normal when i lock to lock the steering then over time becomes off again Sent from my Nexus 5X using Tapatalk
  10. Nice one I'll give the a go thanks Sent from my Nexus 5X using Tapatalk
  11. Could be crank position sensor mate Sent from my Nexus 5X using Tapatalk
  12. Basically the car pulls to the left ever so slightly and the steering gets heavy. But to solve this when i take the power steering reservoir cap off and turn the steering lock to lock a few times the car drives as straight as an arrow and the steering feels a little lighter. It's had a new cap. The reservoir had residue on it when i bought it but that was because the previous owner over filled the reservoir. There is also a slight weep at the join in the ps hose at the front of the engine Sent from my Nexus 5X using Tapatalk
  13. Nice. 406 though lol Sent from my Nexus 5X using Tapatalk
  14. Just to add it's an 03 t5 2.3 Sent from my Nexus 5X using Tapatalk