T5bobbo

Full Members
  • Content count

    27
  • Joined

  • Last visited

Everything posted by T5bobbo

  1. As in title if not where can i i get one? Thanks in advance Sent from my Nexus 5X using Tapatalk
  2. Thanks for that. Although removing them isn't a problem as I've done loads of research on the "internet" on how to remove them. it's just which way is the best again hence my original question lol. Now can you see my original frustration lol. And my original post would have got me band lol. Sent from my Nexus 5X using Tapatalk
  3. I've looked and looked hence my original question of someone on here might have the mcgard removal kit. Thanks for your help. Bloody hell did someone just help me without been a complete bell smith? Sent from my Nexus 5X using Tapatalk
  4. Bottom lip came out and everything lol Sent from my Nexus 5X using Tapatalk
  5. If you read the question instead of trying to impress men on the internet with your wit then i think you will find the internet doesn't have the contents of everyone's garage/workshop tools which would be useful. You just couldn't wait to use that " iam a clever dick" link lol. Sent from my Nexus 5X using Tapatalk
  6. I upgraded the top mount about 3 months ago which made the car feel better now the bottom mount has failed. Might just order a new OEM one for now as Iam moving house soon and can't be bothered to mess about with it. Can someone tell me the torque settings as Iam yet to but a Haynes Sent from my Nexus 5X using Tapatalk
  7. Oh and it's a manual Sent from my Nexus 5X using Tapatalk
  8. It's an 03 plate s60 2.3 t5 250 bhp. Got a knock everytime i lift off or accelerate or get the biting point. Checked the transmission mount and the small bush has warn away so wondering if an uprated version is the better option Sent from my Nexus 5X using Tapatalk
  9. Gave it a wash scrubs up well Sent from my Nexus 5X using Tapatalk
  10. Basically the car pulls to the left ever so slightly and the steering gets heavy. But to solve this when i take the power steering reservoir cap off and turn the steering lock to lock a few times the car drives as straight as an arrow and the steering feels a little lighter. It's had a new cap. The reservoir had residue on it when i bought it but that was because the previous owner over filled the reservoir. There is also a slight weep at the join in the ps hose at the front of the engine Sent from my Nexus 5X using Tapatalk
  11. Nice one thanks that's a great help I'll have a look see the relay later. Plus Iam thinking the tracking is settling back to normal when i lock to lock the steering then over time becomes off again Sent from my Nexus 5X using Tapatalk
  12. Nice one I'll give the a go thanks Sent from my Nexus 5X using Tapatalk
  13. Could be crank position sensor mate Sent from my Nexus 5X using Tapatalk
  14. Nice. 406 though lol Sent from my Nexus 5X using Tapatalk
  15. As in title anyone recommend a decent 10w40 fully synthetic oil. Thanks in advance Bobbo Sent from my Nexus 5X using Tapatalk
  16. Just to add it's an 03 t5 2.3 Sent from my Nexus 5X using Tapatalk
  17. Welcome to the forum Sent from my Nexus 5X using Tapatalk
  18. Many thanks Tim. And thanks tingy Sent from my Nexus 5X using Tapatalk
  19. Hi all. Rob or Bobbo here. Recently bought myself an S60 t5 se. Really happy with it fairly quick for a big old unit. Full Volvo service history 98k miles. Hopefully going to be trouble free:) Looking forward to speaking with you all
  20. Just to confirm Tim is that oil 10w40 for the 03 2.3 turbo t5 engine. Sent from my Nexus 5X using Tapatalk
  21. 2003 S60 with modern interior space ball gear stick if that makes any difference. Sent from my Nexus 5X using Tapatalk
  22. Nice one that's a great help. Iam just looking at updating the rear marker lights, front side, and number plate lights with white LEDs. Have you got a picture of yours. I know they won't fit mine, just been nosey Sent from my Nexus 5X using Tapatalk
  23. So far so good. Had a idle issue which turns out was the maf that got oiled up from a k&n panel filter. Also PSF leak at the reservoir turns out far too much fluid in it. New cap now fixed. General impressed with it. Drove it fairly steady on a run the other day returned 36.2 mpg. Managed to do 470 ish to the tank. Sent from my Nexus 5X using Tapatalk
  24. Hey all. Recently bought a 2003 Volvo 2.3 T5. Love the car. Now as you do when i got the car back i gave it a really good going over and found a bottle of 10W40 part synthetic oil in the pocket of the front seat. Having worked in a motor factors before, I thought this viscosity was odd. So I looked through the service history which is full Volvo, and I confirmed the oil they put in at the dealer was in fact 10W40. So now i come to do an oil change I go to a motor factor and enquire about oil. They are saying 5W40 fully synthetic or 0W30 fully synthetic and no mention of the 10W40. So i rang my local dealer and they said they would put 5W40 in it. I then rang the volvo dealer it was last serviced at and they said 10w40. Just to add the car drives nice. no smoke or oil residue on the exhaust. I am just worried that if i put 5W40 in that the engine might develop leaks. Can anyone confirm what is the oil to use as I am completely confused. Thanks