laggys40

Holset powered s40

58 posts in this topic

13 hours ago, laggys40 said:

Damnnn. My 2nd gear doesn't come anywhere near 100mph,lol. 

It would at 10,000RPM.

Share this post


Link to post
Share on other sites

Exhaust is complete. Went at a different approach, decided to paint it black to protect it from the salt during the winter. I also adapted a 3" stainless pipe to the stock muffler for now. Down the road I'll be gutting it out and straight piping inside the stock muffler it to give it the stock(sleeper look) and approved state inspection look to it. 

https://postimg.org/image/5qgynnbbh/

https://postimg.org/image/ld8810p3h/

https://postimg.org/image/p1xx0hz4d/

https://postimg.org/image/dzsu2251p/

https://postimg.org/image/q2y5pmg3x/

https://postimg.org/image/i7nmat6h9/

https://postimg.org/image/xmr8ro9al/

Share this post


Link to post
Share on other sites

Started up the car for the first time today and she ran!!  Stupid me forgot to tighten the oil feed line on the engine block and made a huge mess,lol. Other than that I have two leaky fuel injectors and still need to extend the o2 sensors wires and replace the timing belt again. There is a small tear and must have gotten hit during install. 

Share this post


Link to post
Share on other sites

Small update. I did a full o-ring replacement on the fuel injectors and not a leak so far. Also did the timing belt AGAIN and noticed why the old one tore on the side. During inspection I found a socket adapter that had fell down into the timingbelt crankshaft area. This must have bee the culprit scene in the first photo.

https://postimg.org/image/igr7u3c0d/

https://postimg.org/image/gss2ffy4t/

https://postimg.org/image/j8tvtag7h/

 

Share this post


Link to post
Share on other sites

Intercooler plumbing is almost done. I took a chance and ordered a stock hy35 boost elbow and it worked out great. The height is perfect and all I needed was a 90 degree elbow with a 3" to 2" coupler so that it bolts right up to the stock intercooler pipe. 

https://postimg.org/image/wiztn7u6l/

https://postimg.org/image/oerpih7rh/

 

 

Share this post


Link to post
Share on other sites

So I did a little detail on the engine bay yesterday. I still have to plumb up the diverter valve and upgrade the cold side pipe of the intercooler to a 3" aluminum bend. Official startup video coming next week, waiting for a part to be imported from sweden right now and wont be in until next wed/thurs.

https://postimg.org/image/rib9o6x71/

Share this post


Link to post
Share on other sites

I ran into a problem on the first road test. I'm blowing oil out the seals on the turbine side. The oil burning is at idle and gets worse with more throttle. I'm pretty sure it's my oil return line causing the issue. The fitting I purchased from ebay/china isnt a true -10an in regards to the inside diameter. Ordering a 5/8 fitting on the turbo and hoping that eliminates the oil blowing past the seals.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now