Herre

Shock while select D, XC70, D5

6 posts in this topic

A question to the expert. I own a XC70, D5, 2011. While selecting D the automatic gear gives a hard bump. The Volvo dealer changed the oil, which worked for one month. They electronically adjusted, which worked for a month. And finally they adjusted the gears, which worked for a few weeks. Its sometimes more frequent then other, even some days completely smooth without any problem. Anybody a suggestion what might be wrong?

Share this post


Link to post
Share on other sites

Hi,
I'm a Volvo tech and and I'm assuming your transmission is a TF 80 SC? If the dealer has updated TCM onto latest software and carried out adaptions then it's a transmission fault. The adaptions are a pain to do but has to have 5 confirmed adaptions in the 4 transmission oil temperature ranges to be done correctly. If done correct then There is a fibre washer inside that gets a a groove wore into it and causes intermittent harsh engagement of drive. It's a hell of a thud when they do it.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Yes, thats the model. He updated the TCM indeed and did an adaptation on all temperature ranges. Both jobs helped but temporarily. Regarding the fibre washer, I understand that they get worn and cause the shock. Is there one specifically or are there severals which get worn?

Share this post


Link to post
Share on other sites

There's a couple that get a microscopic groove in them which can only be seen under a microscope. It causes the oil pressure to fluctuate which causes the shock. We usually fit New transmissions which is a hell of a price. Maybe a good recon in the way forward.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Got it, thanks! Do you think fitting a new transmission is worth it, completely or just the valve house? What would be a very rough estimate of cost? In either way, the shake, does it damage something or is it just uncomfortable?

Share this post


Link to post
Share on other sites

We fit complete transmission assembly and it's about £4000 plus labour, which is rather expensive!! Not seen any fail due to issue though, more of an annoyance. Valve body doesn't cure the prob the washers are internal.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now