T5bobbo

Odd power steering.

5 posts in this topic

Basically the car pulls to the left ever so slightly and the steering gets heavy. But to solve this when i take the power steering reservoir cap off and turn the steering lock to lock a few times the car drives as straight as an arrow and the steering feels a little lighter. It's had a new cap. The reservoir had residue on it when i bought it but that was because the previous owner over filled the reservoir. There is also a slight weep at the join in the ps hose at the front of the engine

 

Sent from my Nexus 5X using Tapatalk

 

 

Share this post


Link to post
Share on other sites

Sounds like something is amiss certainly.

Bought an XC70 a while ago and it had weird steering, it was notchy and squealed like squeally thing, the front pipe on the pump was loose but made little difference tightened up. Was fearing a rack issue so opted for the upgraded PS reservoir, changing that cured all ill's and continues to be AOK 10k miles later.

Share this post


Link to post
Share on other sites

Nice one I'll give the a go thanks

Sent from my Nexus 5X using Tapatalk

Share this post


Link to post
Share on other sites
On 3/27/2017 at 9:45 PM, T5bobbo said:

 

Basically the car pulls to the left ever so slightly and the steering gets heavy. But to solve this when i take the power steering reservoir cap off and turn the steering lock to lock a few times the car drives as straight as an arrow and the steering feels a little lighter. It's had a new cap. The reservoir had residue on it when i bought it but that was because the previous owner over filled the reservoir. There is also a slight weep at the join in the ps hose at the front of the engine

 

Sent from my Nexus 5X using Tapatalk

 

 

 

That's two seperate issues!

Steering pulling slightly left is more likely an alignment issue/worn wishbone bush.

Steering getting heavy (intermittantly, I'm assuming- like the steering is so heavy, you almost can't turn it!). This is commonly the steering control relay and lives under the drivers dash above the clutch pedal.

Your car may not have speed sensitive steering though, so you'll need to check. 

Regards the leaking hose and leaking Cap.....just upgrade to the 05> version. You'll need reservoir (includes a cap) and new pump to reservoir hose, plus two clips. 

Easy fix and will permenantly fix the known older style reservoir issue. They bulge and crack and the caps are rubbish. 

Share this post


Link to post
Share on other sites

Nice one thanks that's a great help I'll have a look see the relay later. Plus Iam thinking the tracking is settling back to normal when i lock to lock the steering then over time becomes off again

Sent from my Nexus 5X using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now